nyc v15.0.0 Release Notes

Release Date: 2019-12-20 // about 1 month ago
  • ⚠ BREAKING CHANGES

    • 🔌 The flow and jsx parser plugins are no longer 0️⃣ enabled by default.
    • Node.js 8 is now required to run nyc
    • Remove NYC_ROOT_ID and NYC_INSTRUMENTER environmental variables.
    • 🚚 The root field has been removed from processinfo files.

    🔋 Features

    • ➕ Add --use-spawn-wrap=true option (#1169) (df4de4d)
    • ➕ Add .cjs, .mjs, .ts, .tsx, .jsx to default extensions (#1110) (914b776), closes #1103
    • 👍 Allow nyc instrument to instrument code in place (#1149) (7783284)
    • ⬆️ Drop node.js 6, upgrade dependencies (#1134) (00c3b34)
    • Filenames relative to project cwd in coverage reports (#1212) (5258e9f)
    • 👉 Use @istanbuljs/schema for yargs setup (#1194) (fd40d49)
    • 👉 Use istanbul-lib-processinfo (#1145) (7943413)
    • 👉 Use source base name to prefix cache files (#1144) (5c1b7a9)

    🐛 Bug Fixes

    • 🚦 Avoid source-map module during signal-exit handler (#1191) (83eb629)
    • 👍 Better error handling for main execution, reporting (#1229) (dfd629d)
    • Correct handling of source-maps for pre-instrumented files (#1216) (8411a26), closes #1208
    • ⬇️ Drop coverage produced by nyc --all for files that were tested (#1155) (fc1bbbf), closes #1113 #1124 #1148
    • 0️⃣ Honor eager setting (false by default) (#1179) (c18fb0a)
    • ✂ Remove vestigial environment variables (#1078) (cfd3da0)

Previous changes from v14.1.1

  • 🐛 Bug Fixes

    • check-coverage: make the --temp-dir option visible (#1101) (b5b67de)
    • cli: Report error if unwanted positional arguments are received (#1100) (57debc1), closes #401